Como instalar pilasengine V1 en Debian 10?

Hola necesito ayuda para instalar pilasengine v1 por lo menos para poder crear juegos tengo muchos planes para crear el juego que voy hacer pero el pilasengine 2 me cuesta usarlo y quisiera saber como instalar pilas en Debian 10 este sistema salio hace 1 semana, y siempre me dice que falta otras cosas.
隆Necesito Ayuda!:woozy_face: :woozy_face:

Hola @SAIDBROS, 驴probaste seguir las instrucciones de instalaci贸n del repositorio de pilas 1?

Tambi茅n hay algunas instrucciones espec铆ficas de debian en el foro:

Por cierto, 驴qu茅 error te muestra?

gracias por escribirme @hugoruscitti el error que aparece es este

Traceback (most recent call last):
  File "/usr/local/bin/pilasengine", line 4, in <module>
    __import__('pkg_resources').run_script('pilas==1.4.12', 'pilasengine')
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 666, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 1446, in run_script
    exec(code, namespace, namespace)
  File "/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/EGG-INFO/scripts/pilasengine", line 6, in <module>
    import pilasengine
  File "/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/pilasengine/__init__.py", line 44, in <module>
    import widget
  File "/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/pilasengine/widget.py", line 14, in <module>
    from PyQt4.QtOpenGL import QGLWidget
ImportError: No module named QtOpenGL

faltan paquete y no se como instalarlo lo intentado todo lo posible y siempre me sale el mismo error estuve en la pagina de GitHub viendo las instrucciones y al final salen peque帽os errores que ignoro

Por el mensaje de error parece que no puede iniciar una biblioteca de opengl que deber铆a venir dentro de PyQt4.

驴Intentar铆as ejecutar este comando?, creo que puede resolver el problema por lo que que comentan aqu铆:

apt-get install python-qt4-gl

bueno lo probe y me salio el mismo mensaje pero mas extendido

Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Traceback (most recent call last):
File 鈥/usr/local/bin/pilasengine鈥, line 4, in
import(鈥榩kg_resources鈥).run_script(鈥榩ilas==1.4.12鈥, 鈥榩ilasengine鈥)
File 鈥/usr/lib/python2.7/dist-packages/pkg_resources/init.py鈥, line 666, in run_script
self.require(requires)[0].run_script(script_name, ns)
File 鈥/usr/lib/python2.7/dist-packages/pkg_resources/init.py鈥, line 1446, in run_script
exec(code, namespace, namespace)
File 鈥/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/EGG-INFO/scripts/pilasengine鈥, line 8, in
pilasengine.utils.iniciar_desde_terminal()
File 鈥/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/pilasengine/utils/init.py鈥, line 325, in iniciar_desde_terminal
_ = pilasengine.abrir_asistente()
File 鈥/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/pilasengine/init.py鈥, line 623, in abrir_asistente
import asistente
File 鈥/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/pilasengine/asistente/init.py鈥, line 16, in
from PyQt4 import QtWebKit
ImportError: cannot import name QtWebKit

@hugoruscitti, cuando ejecuto este comando no funciona ```
sudo easy_install -U box2d

hola @hugoruscitti estaba instalando unas cosas que me faltaban en el pilas y creo que estoy mas cerca ejecute abrir ilasengine pero me salio este mensaje

pilasengine: cannot connect to X server

nose porque se produjo este error :thinking: pero al parecer estoy mas cerca de poder instalar pilas

El 煤ltimo error, que dice 鈥渃annot connect to X Server鈥, me parece que sucede porque estas usando el usuario root para abrir pilas, 驴puede ser eso?. Deber铆as abrir pilas con tu usuario normal, sin ser root.

Parece que esto tambi茅n te puede servir: https://askubuntu.com/questions/175611/cannot-connect-to-x-server-when-running-app-with-sudo

gracias @hugoruscitti.
hice lo que me dijiste pero aun sigue dando el error

Traceback (most recent call last):
File 鈥/usr/local/bin/pilasengine鈥, line 4, in
import(鈥榩kg_resources鈥).run_script(鈥榩ilas==1.4.12鈥, 鈥榩ilasengine鈥)
File 鈥/usr/lib/python2.7/dist-packages/pkg_resources/init.py鈥, line 666, in run_script
self.require(requires)[0].run_script(script_name, ns)
File 鈥/usr/lib/python2.7/dist-packages/pkg_resources/init.py鈥, line 1446, in run_script
exec(code, namespace, namespace)
File 鈥/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/EGG-INFO/scripts/pilasengine鈥, line 8, in
pilasengine.utils.iniciar_desde_terminal()
File 鈥/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/pilasengine/utils/init.py鈥, line 325, in iniciar_desde_terminal
_ = pilasengine.abrir_asistente()
File 鈥/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/pilasengine/init.py鈥, line 623, in abrir_asistente
import asistente
File 鈥/usr/local/lib/python2.7/dist-packages/pilas-1.4.12-py2.7.egg/pilasengine/asistente/init.py鈥, line 16, in
from PyQt4 import QtWebKit
ImportError: cannot import name QtWebKit

pero cada vez estoy mas cercade instalar pilasengine V1 es posible que sean 2 cosas

1)es posible que el pilas solo funcione en la version de 64 bits
2)falta algun repositorio importante pero no se cual es.

la razon que entro como root es para que sea mas sencillo la instalacion y descargas de varios archivos pero creo que falta poco para poder usar pilas por fin talvez en otro momento lo vuelva intentar :relieved: